Minecraft – Vanilla

Let us pick the best plan for you

Already know what you want? View our full list of packages here

What Version Will You Be Running?

Different versions of Minecraft have different requirements

OLder

Versions older than 1.7

1.7.10-1.11.2

All versions from 1.7 to 1.11.2

1.12.2-1.16.5

All versions from 1.12 to 1.16.5

1.17.1

All versions of 1.17

Latest (1.18.x)

All versions of 1.18